Project

General

Profile

Bug #393

Priority enumeration not loading on 0.11

Added by Benoit Duffez over 8 years ago. Updated over 8 years ago.

Status:
Rejected
Priority:
Low
Assignee:
Category:
Issues
Target version:
Start date:
11/25/2013
Due date:
% Done:

0%


Description

User feedback:

Found a bug in .11 that appears to cause the status priority enumeration to not load causing all issues to have blank priority.

https://play.google.com/store/apps/details?id=net.bicou.redmine&reviewId=Z3A6QU9xcFRPRjREYjB4cFQ4NE1jMWxpeDRYaXIwb3M1eExPdFBJM2xFakZ2d1hmUy1Pb3A1VkpaaG1BbmR0YzhIVm1hbHgxb2JiLVhOcDh2d3JTRHNGRmpB

History

#1 Updated by Benoit Duffez over 8 years ago

Additional testing done:

I tried the fix you suggested but the priority enumeration remained empty.

I tried a few other things to help characterize the bug:

  • Deleting the redmine server account and re-creating it -- enum still empty
  • Changing one of the priority values via web to a simple string (mine all have spaces in the names, just to help eliminate that factor) -- enum still empty
  • Creating a new issue via app -- dropdown for enum empty as well, however after creating the issue the window that showed up displaying the newly created issue showed the default priority value. So the dropdown was blank, but it used the default value anyways and correctly displayed the name. This was the only instance I could find that showed the value of priority enum. However once I left this screen and went to issues list and selected the new issue, that window showed priority as blank once again.

When I say customized I just mean all the values were altered and some extra ones were added. My priority enum is as follows:
Future Plan
Little Thing
Would be Nice
Could Use
Must Have

No plugins as far as I know the server is a vanilla redmine server that I have hosted through a website called SourceRepo.com.

Prior to 0.11 the priority enum was for sure working correctly, I actually had just downloaded the app a few days prior to that update and tested specifically for that sorting feature.

#2 Updated by Benoit Duffez over 8 years ago

Chased up on issue submitter today. Waiting for his feedback.

#3 Updated by Benoit Duffez over 8 years ago

  • Target version changed from 0.11 to 0.12

#4 Updated by Benoit Duffez over 8 years ago

  • Priority changed from High to Low

#5 Updated by Benoit Duffez over 8 years ago

  • Status changed from 1 to Rejected

Can't reproduce.

Also available in: Atom PDF